Revision 2 not available (showing current revision instead)

Thread failed in function 'process'; cannot proceed

hi there, I love the fact someone is continuing the fgallery project. It's simple but effective. I was tired of 'on-the-go' image scaling stuff that slow down my server.

unfortunately I only managed to create 1 gallery with your code. I wanted to convert them all, but I stumble upon this error:

Image file inspection 100% completed - will now process 663 image files
convert-im6.q16: width or height exceeds limit `/var/www/bartman/foto/2019_Zwitserland/files/2019-07-14_12_19_12.jpg' @ error/cache.c/OpenPixelCache/3802.
convert-im6.q16: no images defined `tiff:/var/www/bartman/foto/2019_Zwitserland/files/2019-07-14_12_19_12.jpg.tmp' @ error/convert.c/ConvertImageCommand/3258.
Thread 2 terminated abnormally: Fatal error:
close failed on "convert" "-quiet" "/var/www/bartman/foto/2019_Zwitserland/files/2019-07-14_12_19_12.jpg" "-compress" "LZW" "-type" "truecolor" "tiff:/var/www/bartman/foto/2019_Zwitserland/files/2019-07-14_12_19_12.jpg.tmp":



Fatal error:
Thread failed in function 'process'; cannot proceed

Tags: Closed

Comments

Hm, can I download the 2019-07-14_12_19_12.jpg image somewhere? I'd like to see whether I get the same error on my system. I guess the best case would be finding that you need to upgrade ImageMagick or something like that?

When I run convert --version the output includes ImageMagick 6.9.10-23 so once we discover a system where it works, we might have a chance of figuring out a solution.

– Alex Schroeder 2019-08-05 11:20 UTC


Now that I think about it, "convert ... width or height exceeds limit" is the key in the error message, I think. And the solution is something you need to do on your system: you might need to increase the limits in your policy file.

On my system, that would be /etc/ImageMagick-6/policy.xml where I have the following set (amongst other things):

  <policy domain="resource" name="memory" value="256MiB"/>
  <policy domain="resource" name="map" value="512MiB"/>
  <policy domain="resource" name="width" value="32KP"/>
  <policy domain="resource" name="height" value="16KP"/>
  <policy domain="resource" name="area" value="128MB"/>
  <policy domain="resource" name="disk" value="1GiB"/>

Try larger values?

Feel free to reopen if this doesn't help!

– Alex Schroeder 2020-08-11 16:13 UTC


This wiki uses a variant of Markdown.

To save this page you must answer this question:

Please write "new issue" into the field below.